Noob - How do I charge my range extender battery?

etgo

Member
Region
USA
Noob - How do I charge my range extender battery?

Will this be like charging the bike unit?
-I just plug the charger port directly to the range extender battery then plug the charger to power outlet?
 

kahn

Well-Known Member
Region
USA
City
northWET washington
@etgo
I really like using the Y cable mentioned above. It simplified charging the two batteries. The Y cable has a connector that plugs into the regular cable and then divides to create two charging cable ends. Just be aware that when using the Y cable, both batteries must be attached at the same time or neither will charge. Use the regular cable to charge one or the other. Use the Y cable to charge both at the same time.
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
I have set my Vado SL (using Mission Control) to "Discharge the Range Extender First". Therefore, I just need to plug the red plug of the charger to the RE and that's it. I also own the SL Y Cable to charge both the main and extender battery together.
 

etgo

Member
Region
USA
Follow up question,

What does this "red circle" do?


274043799_503032134569821_8271727895530156090_n.jpg
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
It is the state of charge indicator. Press the "S" once and 1 or 2 or 3 bars will light up.

Besides, an advice. The Zee Cage II (water bottle cage) has an outset part. When you insert the RE into the Zee Cage, rotate the battery so the cage outset gets into the battery's inset. It will secure the battery against the vertical movement on the ride.
 

etgo

Member
Region
USA
weird.. I pressed mine, nothing happened.

I plug the RE to the bike, TCU detect the it, blue and green lights display.
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
A stupid question: Has your RE been charged at least once?
Put in on charging. You will notice the green bars flashing.
 

etgo

Member
Region
USA
Yes, I plug the bike charger to RE.
I plugged the charger to outlet, charger indicate red light .
Then I plug the charger port to RE.
RE did not indicate any light (no light at all).
After 30mins+ charger indicator turns to green (I assume RE already full charged), unplugged them all.
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
Yes, I plug the bike charger to RE.
I plugged the charger to outlet, charger indicate red light .
Then I plug the charger port to RE.
RE did not indicate any light (no light at all).
After 30mins+ charger indicator turns to green (I assume RE already full charged), unplugged them all.
Strange. Why do not the LEDs work?
Can you check the battery charge with Mission Control after you have connected the RE to the e-bike?
 

kahn

Well-Known Member
Region
USA
City
northWET washington
Yes, I plug the bike charger to RE.
I plugged the charger to outlet, charger indicate red light .
Then I plug the charger port to RE.
RE did not indicate any light (no light at all).
After 30mins+ charger indicator turns to green (I assume RE already full charged), unplugged them all.

Are you pressing on the Specialized Logo nearer the bottom of that display area. Not the LED bars.
 
The Creo battery on its own lights up blue to show battery status on the TCU. When the extender is plugged in, the TCU shows this battery level as green. If the Creo battery in below 50%, then you will just see the green of the extender as this covers the other blue battery level.
 
The Creo battery on its own lights up blue to show battery status on the TCU. When the extender is plugged in, the TCU shows this battery level as green. If the Creo battery in below 50%, then you will just see the green of the extender as this covers the other blue battery level.