Pedal assist doesn’t work anymore on TODO Mountain Rider E-Bike, please help


New Member

A few months ago, I bought a cheap electric bike off eBay, the "TODO Mountain Rider E-Bike", for the price of 990 AUD, shipping included to Tasmania, Australia (from New South Wales, Australia).

It comes with a geared 250W rear-hub motor (Bafang I think), a Shimano Tourney drivetrain and a KT-LCD3 display with control buttons. The display is fully preconfigured out-of-the-box for that specific bike, so I never had to adjust any of the settings.

I’ve been reasonably happy with the bike, given the price, for the first 500 km or so. Until now.

Normally, the hub motor/assist function would activate either when I pedal, or when I push the assist switch. Now, the assist function only works when I push the switch, NOT when I pedal, like it used to. It happened overnight and I don’t remember doing anything to the bike other than maybe dropping it on its side by accident once.

The fact that the hub motor and the assist function still work normally when I push the switch makes me think that it’s not a software issue, and not an issue with the hub motor, but maybe a sensor issue? As in: the control box and LCD don’t seem to detect the pedalling and thus don’t activate the assist. That’s my best assumption anyway.

Unfortunately, because it’s a cheapo, Chinese made, no-name kind of product, there’s no official support for it. The manual is useless. I tried fiddling around with the cabling and cleaning the little part next to the derailleur (see red arrow on photo below), to no avail, and I don’t really know what else to try.

I have the black version, but you can see details here:

Yes, I know, shouldn’t have gone for the cheap stuff, but if this is fixable, then I believe it is still a decent purchase.

Anyway, any help would be hugely appreciated :)



Well-Known Member
Looks like a nice bike to me, except you need a better bell. You got the nice LCD-3 display. Here's the manual for it. I have several bikes set up with the LCD-3.

Yes, that is your pedal assist sensor. ( I call it the crank, not the derailleur.) First make sure its bracket is fixed solid and not swinging loose. There is a plastic disk with probably 8 magnets on the crank. Make sure that is not loose and firmly attached. Then make sure the disk is as close to the sensor as it can get w/o scraping it. If that doesn't get you going, it's electrical.

If you trace the cable back to the controller, it will have a three pin plug. It runs on 4.5-5.0 volts power. Usually, you see a red and black wire. That's power/ground. Check for it. If you can measure the third wire relative to ground with a voltmeter, it will flip between 0 and 4 volts as the pedals turn. You might have to poke pins in the wires or otherwise get creative with your voltmeter.

If you get the power, but no signal, it's probably the sensor. If you get the right power on the pins, and the signal behaves, then it's probably the controller. The senor is only about $10 USD.

Finally, I wonder if you can get the LCD-3 parameters messed up such that PAS doesn't work. Sometimes when you try to reset the trip odometer, you accidentally get into the P settings. It's harder to go from there to the C settings, but can happen. You might post your P and C settings. There's a feature where you can set C9 to password protect the bike. Don't do it.


Active Member
Nice answer harryS, do not think there is in P or C settings that affect that but some settings are a little technical. Maybe just the sensor misaligned a little, some have a little led that lights when it spins around. Also make sure the magnets are all there. On one of my bikes with lcd3 each time I turn it on I need to hold the down arrow for about five seconds until I see assist on the screen otherwise it just uses throttle. Make sure you do not try to the hold button down to early otherwise it goes into settings, just wait 30 seconds.
Last edited:


New Member
Hi harryS and Calicoskies, thanks for the quick replies, and sorry for my late reply, didn’t have access to the bike for a while.

I just did the following:
- check that all magnets are on the disk (they are)
- clean the disk+magnets
- clean the sensor
- check if the sensor has a LED (it doesn’t)
- open the controller box (everything looks healthy inside)
- put the rear of the bike on an improvised stand and test the wires with a voltmeter (steady 5V, even when pedalling)

I also tried Calicoskies’ suggestion of pushing the down arrow on the LCD3, all it does is enable Walk Mode ("Assist" already appears on the screen).

If I understand correctly, it must be a PAS sensor issue. Any advice on where to get the correct one? There seems to be 10 magnets on the disc, wouldn’t want to get the wrong one!

Weirdly, the wires on the sensor cable are red/green/yellow on one side and red/yellow/blue on the other.

My creative mounting system (camping stove on one side, old Playstation 3 on the other!)

Sensor cable, wires are weird colours.

If you’re curious, inside the controller box.

Thanks again!


Well-Known Member
I see you're getting 5 volts across the yellow and green wires on the PAS connector.In that one picture. Then if you move the red probe to the red wire, leaving the black probe on the green wire, that will probably be 4.3 volts.

Edit: On my bike, the 5V signal is the one that flips between 0 and 5 when the magnet passes by. The one at 4.3 volts appears to be the power.

Don't know where you are at. In USA, they're $5 bucks and a month to ship out of China on ebay or $12 dollars and overnite on amazon.
Last edited:


New Member
Yeah nah, no flipping on the 5V signal, nor on the 4.3V one. I also tried passing a bigger magnet in front of the sensor to no avail. I put the probes in all possible combinations in order to determine which signal does what. I get 5V on one, 4.3V on another (power?) and 0V on the last. Poked through the wires close to the sensor, same result.

I’m in Australia. I’ll order a new magnet and report on it (might be a while...). I just hope the new magnet fits, but I’m guessing it’s standardised.

Thanks again for your help.
Last edited: