Problem with Bosch performance line cx motor

andy b

New Member
I am an absolute beginner at thsi!..I have Ghost e MTB with a bosch performance line cx motor..this has done 12000kms in 3 years.Sent the motor to be repaired but decided ts was best to bin

it. I bought a new motor on the net and installed it myself ,The motor runs but does tend to show too high a speed and only 3 of the modes work,,,eco.tour and turbo but at the same level!

Ive probably done something incredibly stupid for you experts..but would appreciate your advice..I didnt have the chance to get the bike to a workshop under these lockdown conditions so tried

it myself.(BTWit has a Purion display)
 

Johnny

Well-Known Member
If you open this thread on Bosch section you will have more visibility. What was wrong with the first motor ?

Is your second motor used ?
 

andy b

New Member
If you open this thread on Bosch section you will have more visibility. What was wrong with the first motor ?

Is your second motor used ?
I absolutely squeezed everything I could from the first motor--probably didnt do it justice.. In the end water got into the motor and destroyed it..I could live with that !

Second motoe was described as new on the net..it looked new..no marks or anything ..perfectly clean..so probably this approach from me is a bit reckless..as I dont have access yet to the software from Bosch to see whats going on
 

Johnny

Well-Known Member
I absolutely squeezed everything I could from the first motor--probably didnt do it justice.. In the end water got into the motor and destroyed it..I could live with that !

Second motoe was described as new on the net..it looked new..no marks or anything ..perfectly clean..so probably this approach from me is a bit reckless..as I dont have access yet to the software from Bosch to see whats going on


The speedometer is tied to the wheel circumference and Bosch pretty much locks it, you may take it to a dealer to see if they can change it. For support levels again a software update may resolve things, take it to a Bosch dealer they can diagnose it fast with their dongle.
 

andy b

New Member
Thanks for that..it was probably very optimistic of me to think I could just basically bolt on the motor without any problems..just thought I would risk it!