Rad Mini Brake Squeal

murbot

Member
Region
USA
City
MOUNT AIRY, MD USA
Less than 10 miles on the bike. It squeals over about 3-4" section of the rear rotor. I cleaned them yesterday. Will try again tomorrow maybe with acetone.
Removed front and rear rotors
Soaked rotors 20 minutes in 90% alcohol, then wiped thoroughly with lint free cloth
Wiped pads down with 90%
Sanded rotors and pads with 320 grit and a block (have done and seen this done at shops before),

I took it for a spin to look at Christmas lights night (so great). And a quick 20 minute ride this morning. Squeal starts up when the power to the motor cuts off and I'm not applying the brake. If I stop pedaling, the sound lightly starts for 1-2 revs, then by the 3 time around, it's hitting that squeal, squeal, squeal pretty loud until I apply the brake either hard or light or start pedaling and the squeal stops immediately.
Any idea why the squeal starts and stops when the motor stops and starts respectively?
 

Timpo

Well-Known Member
If you only have 10 miles, the brake probably needs to be broken in.

Also, maybe it's not adjusted properly?
 

AHicks

Well-Known Member
Region
USA
City
Snow Bird - Summer S.E. Michigan, Winter Gulf Coast North Central Fl.
Tempo, our OP has posted his question in 2 places, both here and the general section. If you check his note in the general section it appears it was caused by a set up issue and has been resolved. Not sure why he didn't circle back here to mention that. Likely busy out riding his new bike and forgot to. The evil of double posting....
 

murbot

Member
Region
USA
City
MOUNT AIRY, MD USA
Tempo, our OP has posted his question in 2 places, both here and the general section. If you check his note in the general section it appears it was caused by a set up issue and has been resolved. Not sure why he didn't circle back here to mention that. Likely busy out riding his new bike and forgot to. The evil of double posting....
You are correct. It was a double post. Realized it might be better placed here and was falling over myself with the joy of setting things up. No point in using the forum if I don't post end results on my own questions once resolved. Still getting accustomed to how helpful and responsive folks are here. :)

But yeah, I found that video just after figuring it out. I lacked an understanding of the caliper and mount adjustability. I get it now, but couldn't find those videos with terms I searched for until I figured it out and knew what to reference. :) Apologies for the double'ish post. I usually check my posts and update after results.

I feel the joy of riding like when I was a kid and when I started MT biking in the mid-late 90's.

Thank you again!!