"Service Indicator" on My Purion Display

MrLibraryMan

Member
Region
USA
After today's ride on my Trek Allant+ 7S, I noticed an unfamiliar wrench icon in the lower right area on my Purion display that, according to the manual, is a "service indicator." However, there's no description in the owner's manual of what that icon means. So, can anyone tell me what this curious icon means and just how urgent is it to get it into my LBS? Can I continue to ride my bike without doing harm to the electronics, etc.?

With only 307 miles on my new bike, I hope it's a simple reminder to have my LBS check over the bike as opposed to an indication that there's an electronics problem.

Thank you in advance!

UPDATE: When I posted the above, no Trek LBS stores near me were open at the time. Today, I was able to reach someone who told me that it's a non-urgent message letting me know that it's time to bring in my bike to have a Bosch diagnostics to make sure everything is OK. He also reassured me that I may continue to ride my Allant+ without concern. Evidently it may show this service indicator every 300 miles or so, according to the Trek guy I spoke to.
 

Attachments

  • IMG_6004.JPG
    IMG_6004.JPG
    195.6 KB · Views: 137
Last edited:

Deacon Blues

Well-Known Member
I have a Purion display on my Cannondale Topstone Lefty 3 and this icon hasn't shown up on my ebike, which has 3000km on the odo.
 

Dallant

Well-Known Member
UPDATE: When I posted the above, no Trek LBS stores near me were open at the time. Today, I was able to reach someone who told me that it's a non-urgent message letting me know that it's time to bring in my bike to have a Bosch diagnostics to make sure everything is OK. He also reassured me that I may continue to ride my Allant+ without concern. Evidently it may show this service indicator every 300 miles or so, according to the Trek guy I spoke to.
Did you learn any more about this? I’m surprised something like this would show up without a reason. I’ve never heard of anyone else with this warning on a Purion.
 

MrLibraryMan

Member
Region
USA
Did you learn any more about this? I’m surprised something like this would show up without a reason. I’ve never heard of anyone else with this warning on a Purion.
Nothing more than what I stated in my update I posted in the original post. Since there is no urgency to have it turned off, I postpone my travel to the LBS due to some surgery I had on my right arm.
 

Dallant

Well-Known Member
Nothing more than what I stated in my update I posted in the original post. Since there is no urgency to have it turned off, I postpone my travel to the LBS due to some surgery I had on my right arm.
Good luck with that. I posted a link to your thread on the Bosch thread. Maybe some of the Bosch guys can shed some light on it.
 

MrLibraryMan

Member
Region
USA
Good luck with that. I posted a link to your thread on the Bosch thread. Maybe some of the Bosch guys can shed some light on it.
Thanks, Dallant! I have a sneaking suspicion that before I picked up my new Trek and requested to have the LBS tech update the firmware (for the 85Nm feature), he triggered something (accidentally?) that caused the indicator to appear around 300 miles. Anyway, after I recuperate I'll ride to my LBS to have a Bosch tech reset that indicator. Thanks again!
 

Dallant

Well-Known Member
Thanks, Dallant! I have a sneaking suspicion that before I picked up my new Trek and requested to have the LBS tech update the firmware (for the 85Nm feature), he triggered something (accidentally?) that caused the indicator to appear around 300 miles. Anyway, after I recuperate I'll ride to my LBS to have a Bosch tech reset that indicator. Thanks again!
Hopefully that’s all it is.
 

fooferdoggie

Well-Known Member
its a choice the bike maker chooses to have it pop up. never saw it on my bulls. plus it gets you in there o get updates you may not do if you don't have any problems.