Shengmilo battery issue

ASantos

New Member
Region
United Kingdom
Hi all
I have a

Shengmilo MX01 26" E-bike E-Mountain Bike 12.8AH 1000W​


The rubber plug that is used to cover where the battery is charged (in chassis bike) it got stuck, when trying to remove it using a screwdriver, a lot of sparks came out of the battery socket and now I can no longer connect the charger, it may have burned, the battery is still working as i was able to run the bike and charge it, once it’s off the bike. Could please someone give me some advice?
Many thanks
 

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
Without a photo I'd guess that you melted the copper pins on the charging port and it needs to be replaced.
It may just need to be cleaned up and you can try to do so with a small metal pick and file and some contact cleaner...but only do this with the battery removed.
 

ASantos

New Member
Region
United Kingdom
Hi all
I have a

Shengmilo MX01 26" E-bike E-Mountain Bike 12.8AH 1000W​


The rubber plug that is used to cover where the battery is charged (in chassis bike) it got stuck, when trying to remove it using a screwdriver, a lot of sparks came out of the battery socket and now I can no longer connect the charger, it may have burned, the battery is still working as i was able to run the bike and charge it, once it’s off the bike. Could please someone give me some advice?
Many thanks
Without a photo I'd guess that you melted the copper pins on the charging port and it needs to be replaced.
It may just need to be cleaned up and you can try to do so with a small metal pick and file and some contact cleaner...but only do this with the battery removed.
Many thanks…please check the pic out, any idea..how I could do it, or get parts in The UK? I don’t have knowledge I’m only a rider.
 

Attachments

  • 0845A669-4E01-4FE4-8D4F-9052C5499A87.jpeg
    0845A669-4E01-4FE4-8D4F-9052C5499A87.jpeg
    183.9 KB · Views: 73

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
Many thanks…please check the pic out, any idea..how I could do it, or get parts in The UK? I don’t have knowledge I’m only a rider.
Looks like you melted a piece of the center pin to the outer shell of the connector. With a small hobby file you may be able to remove it.

I think you meant to link to this or similar...

Remember whether repair or replace.... make sure the battery is removed.
 

ASantos

New Member
Region
United Kingdom
Thank you very much…very useful…especially “always remove the battery” I made that mistake. What tools do I need to assemble those parts... solder? Would it be better to contact a professional...?? does anyone know someone in london??
 

Gionnirocket

Well-Known Member
Region
USA
City
Y. O.
Thank you very much…very useful…especially “always remove the battery” I made that mistake. What tools do I need to assemble those parts... solder? Would it be better to contact a professional...?? does anyone know someone in london??
If you have to ask... Then yes, contact a professional 😊
Did you try to clean up the existing one... Looks like it may be salvageable