SL1 motor users - i.e. Creo, Vado SL, Levo SL

Captain Slow

Well-Known Member
I have a couple of questions:
  1. Has anyone gotten odd readings from the power numbers the bike sends to your computer. I went on a ride yesterday and while the average power numbers look right, the peak power somehow had me at 8,200 watts. Obviously there's no way that can be correct. Wondering if anyone else has seen odd readings like this and if anyone has an actual power meter, how do the readings from that compare to what you get from your SL motor
  2. For those who has used a 2nd set of wheels, does the motor work if you don't purchase the magnet ring to go on the rear hub? If you have a 2nd set and set it up, how hard is it to put the magnet ring on and what does the part cost?

As an aside when I was out riding yesterday I saw a Vado SL on the road for the first time.
 

wrshultz

New Member
I have a couple of questions:
  1. Has anyone gotten odd readings from the power numbers the bike sends to your computer. I went on a ride yesterday and while the average power numbers look right, the peak power somehow had me at 8,200 watts. Obviously there's no way that can be correct. Wondering if anyone else has seen odd readings like this and if anyone has an actual power meter, how do the readings from that compare to what you get from your SL motor
  2. For those who has used a 2nd set of wheels, does the motor work if you don't purchase the magnet ring to go on the rear hub? If you have a 2nd set and set it up, how hard is it to put the magnet ring on and what does the part cost?

As an aside when I was out riding yesterday I saw a Vado SL on the road for the first time.
I read that you must use a rear disc rotor on your second wheelset that has the speed sensor magnet built in. One of the aftermarket wheel posts in this thread may have mentioned the source for these rotors.
 

e-levity

Member
  1. For those who has used a 2nd set of wheels, does the motor work if you don't purchase the magnet ring to go on the rear hub? If you have a 2nd set and set it up, how hard is it to put the magnet ring on and what does the part cost?
rotor.jpeg
 

eddief

Member