Specialized Vado Battery Issue

usammartin

New Member
Good day,
My wifes bike battery 2018 Vado, after charging and disconnected from charger, displays all green indicator lights when I turn on. Normal.
The bike display illuminates, then goes dark except for only the lowest battery cell illuminates and pulses on and off while all the green battery lights remain on steady.
I swapped battery to identical Vado of my bike and the issue followed the battery, to this bike.
Tried to ride to see if motor would respond to speed selection, up or down. No active motor assist.
Sent email Specialized RideCare, no response in a week.
Took to LBS (Specialized Dealer) had firmware updated, did not help. The LBS is talking to Specialized Vado engineer, he thought wiring harness until informed the issue followed battery between bikes. He is too research and contact LBS sometime.
Talked to two Specialized bike shops owners I know, they also are stumped.
Can not find Specialized instructions to properly / fully discharge the battery, or perform a reset.
Known solution or if you know a resource that can help I would appreciate a response.
 

Sierratim

Well-Known Member
The battery acts normal as it charges, but won't communicate to the display controller when installed in the bike. Could be contaminated contacts on the battery. I use a 'plastic friendly' contact cleaner on our Vados. Others have posted good results using a dielectric paste after cleaning the contacts.

0309201133_Film1.jpg


It's fairly inexpensive.

You might consider also posting to the Specialized section of this forum to get more responses from other Vado owners.

Good luck.
 

usammartin

New Member
The battery acts normal as it charges, but won't communicate to the display controller when installed in the bike. Could be contaminated contacts on the battery. I use a 'plastic friendly' contact cleaner on our Vados. Others have posted good results using a dielectric paste after cleaning the contacts.

View attachment 54559

It's fairly inexpensive.

You might consider also posting to the Specialized section of this forum to get more responses from other Vado owners.

Good luck.
Thank you for the possible corrective action. I tried both points with no change in the problem.
I will jump over to the Vado area and see if anyone their might have experiences to lend.
I am outside warranty so I might remove the connector screws and pull the connector to check wires on the back side.
Enjoy the day.
 

GreenBikeRod

New Member
Thank you for the possible corrective action. I tried both points with no change in the problem.
I will jump over to the Vado area and see if anyone their might have experiences to lend.
I am outside warranty so I might remove the connector screws and pull the connector to check wires on the back side.
Enjoy the day.

Did you resolve this issue? My wife's bike is experiencing this very same issue. This started when her bike tipped over while on a long ride.
 

Biker baby

New Member
Looking for a specialized vado battery with charger. Battery very hard to get in. Mine fell out while driving to bike trail. Hate the bike first day I came to pick it up. Dealer refuse to cancel sale. Bike is 18 months old used april- sep 2020. aprox 500 miles. Broke ankle last year different event was unable to ride 2019. Why did I buy it- good question= great saleman