Specialized Vado/Como. Display startup screen - remaining range?

PaD

Well-Known Member
I have a Vado 4 and the basic LCD screen.
Today was first time I saw what I assume is estimated remaning range before screen goes to normal view. I know the battery symbol has been lit up before the entire screen with all info appears. Can’t remember seeing those figures before. Strange.
Picture is taken after todays ride. I noticed this morning it said 87km and during a startup after a break it read 64km.
I turned battery off when I came hone and then restarted.
DF1573AC-3187-4648-B9AE-FB0833ECEC92.jpeg
 

john csokmay

New Member
I have a Como 3.0 with the basic display also. During power up, mine appears to do the same thing, but in miles. Typically, I get about 50 miles per battery charge. On power up tonight, I saw 37 miles briefly, then after fully powering up it shows the current trip distance. In this case it displays 13 miles and 4 bars of battery remaining. I reset the display after each time I charge the battery so I can track mileage and elapsed time for a full charge. I've got about 1800 miles on my Como, but never noticed this fleeting message before. Sometimes I wish we could get more information from Specialized about the way our e-bikes work.
 

PaD

Well-Known Member
I have a Como 3.0 with the basic display also. During power up, mine appears to do the same thing, but in miles. Typically, I get about 50 miles per battery charge. On power up tonight, I saw 37 miles briefly, then after fully powering up it shows the current trip distance. In this case it displays 13 miles and 4 bars of battery remaining. I reset the display after each time I charge the battery so I can track mileage and elapsed time for a full charge. I've got about 1800 miles on my Como, but never noticed this fleeting message before. Sometimes I wish we could get more information from Specialized about the way our e-bikes work.
Thank you for responding.
I’ve had my bike for about 7 weeks and have done approx.1250 - 1350km. Funny I haven’t noticed this feature until now. My odo skips kms sometimes when powering down so I’m not sure about the total distance as I haven’t documented every trip meter reading.
I agree with you about getting more info from Specialized.
 

MarktheC

New Member
That is a "next service" reminder. It can be set for set number of days, or a set number of kms, and starts counting down when near the limit. I understand the dealer can reset the next reminder when they service your bike. When it runs out, nothing happens except it will remind you "0 km" every time you startup.
(Source: I had the same display appear myself and emailed the NZ distributer and they explained it, and the count went down to 0 with no problem.)
 

PaD

Well-Known Member
That is a "next service" reminder. It can be set for set number of days, or a set number of kms, and starts counting down when near the limit. I understand the dealer can reset the next reminder when they service your bike. When it runs out, nothing happens except it will remind you "0 km" every time you startup.
(Source: I had the same display appear myself and emailed the NZ distributer and they explained it, and the count went down to 0 with no problem.)
Thank you!
That explains why I haven´t seen it before and also why the number didn´t go up this morning after battery charging.:)
Not a word about this from my dealer.
I must admit I hadn´t looked carefully at the RETAILER SERVICE SCHEDULE in the Vado/Como user manual. I did however ask the sales guy where I bought the bike about a first service but he didn´t mention the 1000km service, he just said come back after summer.
This was when I picked up my bike after motor replacement first week of August. (200km on the odo with the old motor)
I have a service scheduled to next week as I called him last saturday about a few thing that doesn´t seem right and he was surprised that I already had almost 1000km on the odo.
My dealer includes 2 services during the first year of a new bike.
 
Last edited:

gyurrci

New Member
Thank you guys, I was just looking for the exact same issue. :) I bought a dealer's demonstration bike (Vado 4.0 2018) with 24months warranty and 501km usage (this is only 2 weeks cycling for me). I got 35% discount and when I first turned on home I just saw a warning icon and a 0d sign. The manual is a trash, the only thing I found about warning that the exclamation mark means warning signal. Nothing else. :rolleyes: