ST 1 error code

Has anyone encountered a "ICCURR" error code on a Stromer ST 1. Riding along yesterday at 18mph in ECO mode and all of a sudden the bike comes to an abrupt stop like it went into RECOUP 2 mode. Turned off display and back on and display shows normal info but no assist, in fact, there is so much resistance in the rear wheel/hub you almost can go 3 mph, displaying the "IRRUCC" code on the display. It's going to the shop this morning but thought I'd post this in the mean time.
 

opimax

Well-Known Member
I am not familiar with that one. I would do the standard full reset of my bike. Disconnect all connectors wait 30 min and try again... remove the battery. connector to the the display, 3 connectors by the wheel,1 power and and 2 data bus . there is also 1 for the brake on the handle bars , may as well disconnect that also.
 

leepear

New Member
I have a stromer with a defective motor. That code comes on with any strain on my motor. I think it is really bad because my bike now only works with the throttle after you peddle it to speed peddle assist just goes directly into that code and wont work. The reset will not work but try it.
 

Ravi Kempaiah

Well-Known Member
Has anyone encountered a "ICCURR" error code on a Stromer ST 1. Riding along yesterday at 18mph in ECO mode and all of a sudden the bike comes to an abrupt stop like it went into RECOUP 2 mode. Turned off display and back on and display shows normal info but no assist, in fact, there is so much resistance in the rear wheel/hub you almost can go 3 mph, displaying the "IRRUCC" code on the display. It's going to the shop this morning but thought I'd post this in the mean time.

Our tech says..

"ICUUR error on an ST1. That indicates Incorrect current in the motor controller which is inside the motor case and not serviceable separately. In other words indicates a bad motor. Hope this helps"