Stromer display locked and can't enter numbers

FlyRiceLake

New Member
When turn on display, display says locked and even though Main battery fully charged, display appears to show it to be completely empty.

Display says locked, and Display shows 4 zeros with first zero flashing, however the plus minus keys do not change the flashing or any of the zeros.

Have replaced display battery and disconnected and reconnected motor connections and brake connectors.

Anyone have any ideas

Thanks
 

JoePah

Well-Known Member
Looks like you may have locked out your controls.

Hold the on off button for 4-6 seconds.. the display should flash

You will have to enter a 4 digit security code..

On my Stromer the default was 1-2-3-4

On my Stromer the way to enter a number was to press the toggle switch on the right side to increase the number, left side decrease the number. Then press the on off button to move to the next digit...

Look at page 24 of this St1 Manual
(Link Removed - No Longer Exists)
 

FlyRiceLake

New Member
Looks like you may have locked out your controls.

Hold the on off button for 4-6 seconds.. the display should flash

You will have to enter a 4 digit security code..

On my Stromer the default was 1-2-3-4

On my Stromer the way to enter a number was to press the toggle switch on the right side to increase the number, left side decrease the number. Then press the on off button to move to the next digit...

Look at page 24 of this St1 Manual
(Link Removed - No Longer Exists)
Yes, this is normal, my problem is it does not work now unfortunately.
 

Ann M.

Well-Known Member
Yes, this is normal, my problem is it does not work now unfortunately.

In case you're still having issues about programming and your console, here's a link to Stromer's online support pages which look pretty good.
http://www.stromerbike.com
That page will also have all the other links you need to reset your console.

Please let us know if this helped, if not, we all can go to the next level to help you with your ebike.
 

JoePah

Well-Known Member
Yes, this is normal, my problem is it does not work now unfortunately.

Oh well that stinks.. There is a battery inside the Stromer display..On my other devices when that battery starts going the device locks up.

I couldn't find instructions to disassemble the display module.
 
Last edited:

FlyRiceLake

New Member
Yes, I have all the stromer manual pages, but display not working per the manual. I have changed out the display battery with no help.
 

JoePah

Well-Known Member
Yes, I have all the stromer manual pages, but display not working per the manual. I have changed out the display battery with no help.
Well then call the American Distributor.. I htink they are in San Diego now.

800-819-4262
858 863 8170

I forget which one worked for me. They were very helpful when i needed a bike key and an charger adaptor. OR you can bring to your dealer if you think they're good.
 

Dave Delaney

New Member
Make sure that noe of tthe three control buttons are stuck in a depressed position. This happen to me when my ST-1 was new.
 

FlyRiceLake

New Member
Problem was the display had failed. Rich at Lenny's Ebike replaced and all is well. Great support and customer responsiveness by Rich!