TCU problem - settings not saved

jtooley

New Member
I have a Turbo Vado SL 4.0. If I use the Mission Control application with the bike, none of the settings are saved. For example, if you change the tuning settings, units of measures, etc they are not saved between rides. The tuning settings says “profile saved” when you update it, but the values return to the factory values immediately. I am trying to figure out if this a Mission Control application problem, firmware problem, or a TCU problem.

The LBS replaced the TCU last week, and I discovered this new problem with the TCU after I repaired the TCU with my phone.

Any solutions before I return the bike to the LBS for their troubleshooting?
 
Last edited:

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
return the bike to the LBS for their troubleshooting
This.

The e-bike behaviour you have described is far from being normal. The LBS has to be able to fix the issue, and demonstrate in front of you everything is working properly. That's the Specialized Warranty, and you paid a lot for it.
 

jtooley

New Member
Update. I took the bike to the LBS. I learned 2 things, but not sure which was the root cause
1. The LBS didn’t have the replacement TCU properly installed. When they put the bike on the machine to troubleshoot it indicated it found new components. So he reinstalled the TCU, and reflashed the firmware.
2. The app worked with the bike on his phone, but not mine. So I reinstalled the app, and it still didn’t work. I then removed the iOS bluetooth settings, reinstalled the app, paired the bike, and it worked.

So my conclusion is that when you replace the TCU, you need to do a “full reset” of the bike and the app to avoid any potential issues.