Torque sensor

Delta

Member
Does anyone know where to buy a torque sensor for the Bafang Ultra motor. I cannot find one anywhere.
 

Thomas Jaszewski

Well-Known Member
Does anyone know where to buy a torque sensor for the Bafang Ultra motor. I cannot find one anywhere.
There is practically no parts stream for Ultra motors. Unless you can enlist the help of a OEM using the Ultra you're likely SOL!
Which eBike are you having an issue with?
 

Delta

Member
That is kind of what I have learned about the Ultra parts availability. My bike is the m2s Ultra Fat, 2 years old. I have to say I have never been happy with it's power (or lack there of). I compare this bike to my 750 watt rear hub bike, the rear hub Addmotor P7 550 is much peppier. Thanks Thomas.
 

AHicks

Well-Known Member
Have you talked with m2s?
Have you considered/looked into a cadence sensor? Is that even possible on an Ultra?
 

Delta

Member
I did talk to m2s early last week and they said they were going to try to find some info on the problem I was having. At that time I was trying to determine if it was definitely the torque sensor or possibly the controller. Since then I have determined it is definitely the torque sensor. I left a message at m2s on Thursday but have not heard back from them yet. I have no idea if a cadence sensor could be used on the Ultra, maybe some Ultra guru would know how to install one but I don't.
 

bobgren

New Member
I did talk to m2s early last week and they said they were going to try to find some info on the problem I was having. At that time I was trying to determine if it was definitely the torque sensor or possibly the controller. Since then I have determined it is definitely the torque sensor. I left a message at m2s on Thursday but have not heard back from them yet. I have no idea if a cadence sensor could be used on the Ultra, maybe some Ultra guru would know how to install one but I don't.
Delta, my pedal assist stopped working on my FLX gen 3 trail. Throttle works fine. Error 21. Does this sound like a torque sensor problem? Don't know how to troubleshoot problem.
 

BlackHand

Active Member
Delta, my pedal assist stopped working on my FLX gen 3 trail. Throttle works fine. Error 21. Does this sound like a torque sensor problem? Don't know how to troubleshoot problem.
 

Delta

Member
FLX gen 3 trail
Hi bobgren. As BlackHand noted if the error code 21 indicates "speed sensor", that hopefully is your problem. If the little disc attached to your spokes moved out of position the speed sensor will not read your wheel turning, so check that first. Or the speed sensor itself could have gone bad or maybe it has a loose electrical connection where it attaches inside the motor. In my case there was no error code, and by a process of elimination I determined that my torque sensor had failed. Unfortunately Bafang has chosen not to make torque sensors for the Ultra motor available.
 

Delta

Member
Here is an update on my torque sensor problem. In October I found a company "Green Bike Kit" (GBK), that said they would look into getting the torque sensors for the Bafang Ultra motor. In late Oct. they (Anna) got back to me and said they now have them. I ordered it and received it in early Nov. and installed it in the motor last week. Today Nov. 15th. I reinstalled the motor back into the bike and the pedal assist now works. The original torque sensor was two years old and had 970 miles on it. The new torque sensor cost $108.50 plus $10 and change for shipping.