Trouble turning turbo on

kermit_xc

Member
this happened twice in a row:

- push power button in the morning (charged night before and unplugged after charging complete)
- diagnostic check blinks twice at end (no error codes on display)
- bike turns off after lights flash / coming on briefly
- repeat to no avail
- take the bike on a quick spin while off
- push power button and all is good


anybody ?
 
My power button is a little finicky, but I haven't had that issue. I've found that I have to hold it down for about 5 seconds and then let go at just the right moment or it fails to turn on. When that happens, the next press, no matter how brief, turns it on.

Also, for turning off at the end of a ride, I need to press it for just the right shortness of time (about 1/2 second) if I press too long (like a full second) it doesn't turn off and I have to try again.
 

Marko

Active Member
Could try the reset procedure;

- Turn battery off

- Remove battery

- Turn on, wait 5 sec, turn off again

- Install battery

- Turn battery on

I've noticed that after longer periods of time I need to press the power button the 2 seconds as is said in the manual, but if I come back in like 15 min, the battery turns on instantly after pressing.
 

John Dombrowski

Active Member
I have noticed all the problems you guys are saying here on my wife's base Turbo. Definitely a lot of bugs in their power switch.
 

Allan47.7339

Active Member
I take the battery out to charge at work. A couple of times I have had startup errors because I did not seat the battery correctly.
 

Allan47.7339

Active Member
The connector pins would be off a hair and not make contact. The upper connector has a flexible mount so if it's slightly misaligned you can still lock the battery in the frame but there will not be a connection. I would have to unlock the battery and reinstall. You can insert the battery an give it a little rocking and you can hear it pop in place.
 
Last edited: