Turbo (hub drive) powers on, lights cycle, but no power to wheel

ROJA

Active Member
Has anyone seen this? Battery is charged and everything appears to be normal but there's no power to the wheel. I tried turning on/off a few times and even removed the battery.

Any ideas for things I can check myself before going to the shop?

It was stored for the last 2 weeks in weather from 40-60F with the battery at around 55-60%.

Thanks for any tips!
 

bazzapage

Active Member
Obvious thought is the connector at the back. Might need some cleaning? My only major has been the connector where the battery mates with the bike. I have had to replace it as it wasn't making a good connection (I tried to 'help' it with some aluminium foil which then resulted in a melting incident, so don't do that!).
 

Allan47.7339

Active Member
I would check the connector at the top of battery. I was having an issue where the motor would suddenly not have power but lights and display worked. I replaced the connector and the issue went away. I used to charge the battery off the bike an had a lot more cycles inserting the battery. There is a post from bazzapage with the part number and link.