Turbo Vado 3.0 Battery Charge Cut Off Amount

Jim5099

New Member
Region
USA
I have a 2019 Turbo Vado 3.0. My battery cut off power to the motor when it hit 5% during normal temperatures (which I think is normal). On a recent cold ride, temp was about 35f (1c) with wind chill of 25f (-3c). The battery cut off power to the motor at 12% when I went to turbo mode. Tried turning battery on/off and different power levels but could not get the battery to power the motor again.

I'm just wondering if this is normal.
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
The 5% cut-off value is normal. I cannot comment on the strange cut off at 12% because my only long ride at low temperature this Winter (that I precisely recorded in BLEvo) didn't give any conclusive answer.

That was a metric century ride at 30-32 F. I decided to replace the first battery when its charge dropped to... guess how much? 12%! Yet that was not because of any cut-off: I just found myself at a place where I found swapping first and spare battery comfortable and safe.

I guess your riding in Turbo mode at 12% and at low temperature made the system decide to cut off the power for the battery safety. I cannot, however, say was it normal or not! (Also bear in mind your Vado 3.0 has a smaller battery than my 5.0, so the cut-off happened at a relatively higher battery discharge rate than it was in my case).
 

Jim5099

New Member
Region
USA
The 5% cut-off value is normal. I cannot comment on the strange cut off at 12% because my only long ride at low temperature this Winter (that I precisely recorded in BLEvo) didn't give any conclusive answer.

That was a metric century ride at 30-32 F. I decided to replace the first battery when its charge dropped to... guess how much? 12%! Yet that was not because of any cut-off: I just found myself at a place where I found swapping first and spare battery comfortable and safe.

I guess your riding in Turbo mode at 12% and at low temperature made the system decide to cut off the power for the battery safety. I cannot, however, say was it normal or not! (Also bear in mind your Vado 3.0 has a smaller battery than my 5.0, so the cut-off happened at a relatively higher battery discharge rate than it was in my case).
Thanks Stefan! Quite a coincidence you switched out your battery at 12% (and probably a good idea). Next time I ride in very cold weather I'll stay out of turbo mode as it seems to put too much stress on the system. Thanks again.