When is Levo odometer info reset?

Shoe73

New Member
Hi I just bought a used 2018 Turbo Levo. The battery has only 2 charges, and the mileage reported is only 25km. But the bike is clearly heavily used. So it seems they replaced the battery before selling it, but does that reset the odometer? Or was the motor also been replaced?
 

Stefan Mikes

Well-Known Member
Region
Europe
City
Brwinów (PL)
If no mischief was done to the bike, the battery is new and the motor is new. The number of charges is stored in the battery, while the odometer data are with the motor. I would have asked a lot of questions before the purchase...

@Shoe73, can you connect to the bike with Mission Control? It should give you a lot of useful data, for instance the software revision number for the motor and the battery.

Besides, congrats for your new e-bike! The Levo is my dream I better make not come true :) I would feel overwhelmed with that e-bike! Many safe climbs and descents!
 

Shoe73

New Member
Yeah I ordered it sight unseen, took a gamble. How likely is the “mischief”, is that a possibility? I should probably take it to a Specialized dealer.
I have an older Haibike Allmtn RX, and I have to decide which to keep. I like the Levo geometry better, but the motor is quieter and more natural feeling on the Haibike. When I stop pedaling the Levo, I can feel the motor cut out, whereas the Haibike is so smooth that I don’t even notice the motor: it really gives the illusion that I am pedaling with super strength. I wonder if there’s an update to improve this on the Levo
144E884D-0661-47ED-B7BD-705A46EEA507.png

72B4B5A1-DBEB-46EC-BB5D-3417A5500D4E.png
 

rede

Member
I have a 2016 Levo, second one actually, as first was replaced under warranty. Now have about 3600 miles on bike, and on third motor. I believe the latest battery firmware is 4.17.1, and the motor is 7.1.1
 

Shoe73

New Member
@rede 3rd motor on second bike! How rough are you on this thing, are you going all out all the time, taking huge jumps on it, or what?
 

rede

Member
Actually, not rough at all. It's all back road and smooth trail riding, though I live in a hilly area, and I'm an old man. The first bike had so many issues, they replaced it after a month. The second bike developed some control issues and they replaced the motor and harness at around 1600 miles. This second motor was fine for about 1500 miles and then failed abruptly. I think it was the belt drive, as it was difficult to even turn the crank. The third motor has been working well for 600 miles or so, and I believe it may be an updated design as the temperature rise is much less than the previous motors. That may also a firmware/software improvement. BTW, my odometer was reset with each motor change. I have a separate Vectra unit, and have kept track of the total on that.