Winter Riding in New England - March/April 2016

Douglas Ruby

Well-Known Member
Wow! Yesterday (Mar. 8) the temps hit low 60's and today the mid-70's. What a time to ride. Yesterday I made 27 miles, staying at ECO70 and averaging around 17+ mph over a rolling ride with perhaps 1000 ft of climb. My battery went from 98% down to 26% in 27 miles.

Today (March 9) I took a different ride. I went 4 miles at full TURBO on rolling up and down rural roads, and then 12 miles with my daughter in ECO70 on the rail trail. The rail trail is very flat with a net 200 ft. drop over its length. The down hill helped as I was able to average 18 mph without hitting the Turbo button. Then I was racing the sun on the way home and averaged 20 mph over a 10 mile stretch in Turbo mode. I still has 26% left when I got home and averaged 18.3 mph over the full length of the trip.

53 miles in two days. Not bad for winter just outside of Boston.
 
Last edited:

Douglas Ruby

Well-Known Member
Just went on another ride today (March 12). 18.3 miles @ average of 19.7 mph (55 min 45 sec). I went full TURBO and had 36% battery left. I also used MapMyRide for the first time (because my wife can do live tracking). The ride had a total climb of 600 ft. I had one mile interval with a speed of 27 mph! Lots of fun. My winter week is now at 71.3 miles.
 
Last edited:

Douglas Ruby

Well-Known Member
Well, officially it is Spring (March 27)...Hah! Went on a 32.7 mile ride today. Average speed was 15.75 mph using ECO40 for about 26 miles and TURBO for the rest. Total climb was 1222 feet according to MapmyRide. Temperature was 33F when we started and got all the way up to 39F. I had 30% battery left at the end of the ride implying my range with this mix would be around 45 miles. Overcast, gray, and dreary, but I enjoyed the ride.

Total miles since purchase in early December is at 412 so far, but there was no riding in Jan/Feb. My last tweak to the bike will be a Thudbuster ST. Liking this bike a lot.

Doug
 
Last edited:

Douglas Ruby

Well-Known Member
Well, it is no longer March and it is officially Spring. But you coulda fooled me. We had 4-6 inches of snow on Sunday-Monday April 3-4. Today is Wednesday, April 6. It was around 18F this morning. But I got out and did a 30.1 mile ride with my daughter from around 2:30P-5:00P today. Average road speed was around 14.6 mph using exclusively ECO40 on my Specialized Turbo. Starting with a full battery, I finished with 50% left. High temperature was 45F, low around 38F. Very windy and uncomfortable. Now up to around 450 miles on the 2016 Turbo.

This was my first ride with a Thudbuster ST seat post. Having a little dampening in the seat post definitely helps.

Doug
 

Marko

Active Member
Wow, what is NE latitude, 45 deg? I am at 60 and I declare spring first day of March, even though there may be occasional snow. Usually by April there will be no snow around.
 

Douglas Ruby

Well-Known Member
Yet another nice "Spring" ride with my daughter today, April 10. Temps 38F - 50F. Beautiful clear sunny day but some Northwesterly wind. I rode the first 8 miles at ECO50, next 30 miles at ECO40 and last 4 miles at ECO70. Also a few steep hill climbs (total 1 mile?) in full TURBO mode. Total distance was 44.3 miles at an average speed of 14.4 mph with a total climb according to MapMyRide of 1998 feet. I arrived home with 16% battery left. Since November 21, I have managed to put 487 miles on my Specialized base Turbo, only one ride of which was in "Spring-like" weather, and that was in early March with temps in the high 60'sF!
 
Last edited: