X7 discussion

RMK!

Active Member
I have a Feb 2020 X7+ and my only interaction with the controller menu was to confirm my wheel size was 24". Mine is all factory settings (assuming there is such a thing) and using PAS 3 on flat ground, the throttle only max speed is 25-26. It's 28-29 if pedal in 8th gear.
 

PatForbes

New Member
I'm sorry as well for the guys and gals having problems with the Eahora Services. And being somewhat embarrassed with my reaching almost 600 miles and enjoying almost every ride. I wish the same for all of you.
 

PatForbes

New Member
I have a Feb 2020 X7+ and my only interaction with the controller menu was to confirm my wheel size was 24". Mine is all factory settings (assuming there is such a thing) and using PAS 3 on flat ground, the throttle only max speed is 25-26. It's 28-29 if pedal in 8th gear.
Exactly. That's more than 40kph. Maybe because my wheel size is set up to 20". I have to change that. Thanks RMK!
 

Mateo's Dad

Active Member
Hey guys, you might want to check your M5 setting as EAhora set them up weirdly maybe to give fake speed reading. P06 is set to 26 should be at 20, P06 is wheel size. P08 is set to 40kph, should be higher. P18 is set to 110 should be 100, P18 is speed ratio.
Let me know what you guys think, and if you messed with the settings.
If P06 adjusts the wheel diameter (from 20-26") then this will affect the speed on the display.

I've heard the X7 can do 30 MPH on throttle only. However, if P06 is set to 26 then isn't it displaying an incorrect speed (faster than what it's actually traveling at)? What if you changed P06 to 20 and retest throttle only top speed? Has anyone verified with a public car speedometer? Or GPS?
 

b-7

New Member
Anybody know what the brake lever model is or how to get replacement parts? I broke the stupid little plastic cover for the fluid reservoir but not sure how to fix it. Now I'm leaking brake fluid when I fold the handlebars over.

BTW I've tested the P06 settings and top speed settings and it doesn't seem to make any difference for me. Tops out at 28MPH regardless of tire size and max speed. Seems like the controller/motor override the display settings to some degree.
 

NYCneed4speed

New Member
Hi All, I echo both “need4speed” and “J-tron”. We also jumped through some fiery hoops getting our fantastic beasts online and operational. Both bikes were missing various bolts and parts and 1 bike the so called “clutch” was broken so the motor was DOA. I made a few hacks like eliminating the rear fenders (they grind on the chain/missing screws) and using a common hardware bolt to attach the rear suspension shock on Green-Mean (see pics). I sent the Black bike off to an ebike repair in NYC and $200 later it is now back and fully functional. Let me say, after all the trials and tribulations the bikes are a DREAM! Everything you are looking for and imagine ebikes will bring to your lifestyle and enjoyment they will exceed your expectations. These things ride like Bentleys, handle terrain and the tough streets of NYC like a Range Rover and fast as an Aston Martin! Unfortunately much of Eahora‘s customer satisfaction score will take a massive hit due to all the ill’s mentioned. We all bought bikes expecting them to arrive intact with all parts, fully functional with available customer service and this simply did not happen. I am still waiting for color screens, bolts, clutch and a Reply! In the meantime summer is speeding away and Q-pause is relaxing so I intend to get the most out of the bikes before summer is over. Anyone experiencing similar issues I advise and suggest to push past the disappointments and failures on Eahora’s part and try your best to get the bikes up and running because you will Love It! Collectively we will tackle and succeed with Eahora! We have American credit backing us so never fear and we are building strong irrefutable cases! So get your bikes fixed, functioning and fit for summer fun! I have figured 98% of the display functions for anyone with M5 display models but will send only via an email request. Here are some pics and I can answer some questions if needed since we have tried and tested. Happy e-biking!
RadRich I'm trying to get my bike fixed; did you have the clutch/motor issues? I'm hoping to fix mine, but not sure Eahora is going to send me replacement. Do you have any links or resources for the Clutch; or did the bikeshop have and replace for you? Going stir crazy and want to ride this beast, but trying to peddle a 70lb bike is too much for me sadly. Any help you have would be greatly appreciated!
 

Burning Buddha

New Member
RadRich I'm trying to get my bike fixed; did you have the clutch/motor issues? I'm hoping to fix mine, but not sure Eahora is going to send me replacement. Do you have any links or resources for the Clutch; or did the bikeshop have and replace for you? Going stir crazy and want to ride this beast, but trying to peddle a 70lb bike is too much for me sadly. Any help you have would be greatly appreciated!
Hi. No it wasn't me who is having the clutch issue (thank got, sounds like a nightmare). I did see that someone was having this problem as few pages back I think. Well guys... a couple of more weeks post op revovery and I can finely take my monster out for a spin...
 

RadRich

New Member
RadRich I'm trying to get my bike fixed; did you have the clutch/motor issues? I'm hoping to fix mine, but not sure Eahora is going to send me replacement. Do you have any links or resources for the Clutch; or did the bikeshop have and replace for you? Going stir crazy and want to ride this beast, but trying to peddle a 70lb bike is too much for me sadly. Any help you have would be greatly appreciated!
Hey Needforspeed! sorry for the delay - So I did a dual action resolution - I sent my bikes to Franks/Danny’s and at the same time logged a dispute with PayPal against Eahora to get them to respond and commit to sending me full hub replacements and mounting screws. While this was happening the bikes were in the shop being repaired. The “planetary gears“ were damaged and needing replacing and luckily they had in shop so I was lucky and grabbed both for each bike. I ate the cost Ugh! I suggest you call the shop - contact me here for all the details: radrich4@gmail.com. Also, if anyone still has issues sourcing rear shock mounting screws I have 2 extras and can ship to you if needed? See pic. Thanx
 

Attachments

RadRich

New Member
Also, the bikes run like a dream now! We even engaged in evening riding and it is quite magical! We will Never pedal again....Ever! LoL!
 

Jg1000c

Member
Hey Needforspeed! sorry for the delay - So I did a dual action resolution - I sent my bikes to Franks/Danny’s and at the same time logged a dispute with PayPal against Eahora to get them to respond and commit to sending me full hub replacements and mounting screws. While this was happening the bikes were in the shop being repaired. The “planetary gears“ were damaged and needing replacing and luckily they had in shop so I was lucky and grabbed both for each bike. I ate the cost Ugh! I suggest you call the shop - contact me here for all the details: radrich4@gmail.com. Also, if anyone still has issues sourcing rear shock mounting screws I have 2 extras and can ship to you if needed? See pic. Thanx
I need that screw. I'll try to pick up at a bike shop.